diff setup.py @ 6000:023d9202481e

setup: use modern bcrypt implementation instead of unsupported old one py-bcrypt has been deprecated by bcrypt, and is no longer developed or supported. bcrypt requires bytestrings instead of strings, use safe_str to ensure they're encoded before they're passed to bcrypt. Also, use check_pw to minimise the number of manual conversions and comparisons. Installation of bcrypt will probably compile a C extension and require libffi-dev.
author Andrew Shadura <andrew@shadura.me>
date Sun, 03 Jul 2016 12:21:00 +0200
parents 3c4b6ddf6735
children b5859022ac69
line wrap: on
line diff
--- a/setup.py	Tue Jun 14 21:23:51 2016 +0200
+++ b/setup.py	Sun Jul 03 12:21:00 2016 +0200
@@ -66,7 +66,7 @@
     requirements.append("argparse")
 
 if not is_windows:
-    requirements.append("py-bcrypt>=0.3.0,<=0.4")
+    requirements.append("bcrypt>=2.0.0")
 
 
 dependency_links = [