diff setup.py @ 8136:1d1f5598702d

setup: bump whoosh minimum version to 2.7.1 to get py3 support Fix: - kallithea/tests/functional/test_search_indexing.py:111 TestSearchControllerIndexing.test_repository_tokenization[content-this_should_be_unique_content-1-group/*] File ".../lib/python3.7/site-packages/whoosh/reading.py", line 241, in expand_prefix if fn != fieldname or not text.startswith(prefix): TypeError: startswith first arg must be bytes or a tuple of bytes, not str
author Mads Kiilerich <mads@kiilerich.com>
date Sat, 04 Jan 2020 01:05:55 +0100
parents 3a9b91e0adab
children 55b4e5cb4866
line wrap: on
line diff
--- a/setup.py	Sat Jan 04 00:45:45 2020 +0100
+++ b/setup.py	Sat Jan 04 01:05:55 2020 +0100
@@ -53,7 +53,7 @@
     "SQLAlchemy >= 1.1, < 1.4",
     "Mako >= 0.9.1, < 1.1",
     "Pygments >= 2.2.0, < 2.5",
-    "Whoosh >= 2.5.0, < 2.8",
+    "Whoosh >= 2.7.1, < 2.8",
     "celery >= 3.1, < 4.0", # TODO: celery 4 doesn't work
     "Babel >= 1.3, < 2.8",
     "python-dateutil >= 2.1.0, < 2.9",