diff setup.py @ 6555:213085032127

gearbox: make a make-config sub-command available again Drop the old kallithea-config command line tool and rework it to a replacement for the make-config paster command. Make-config was experimental in paste, it doesn't exist with gearbox, it was tied to pylons, and we already have the luxury problem of having two ways of doing almost the same thing. This is a good opportunity to get rid of one of them. This replacement tool is Kallithea specific and doesn't need to be told that it is Kallithea it has to create a config file for. The command should thus perhaps be given a Kallithea specific name instead of the very generic name ...
author Mads Kiilerich <madski@unity3d.com>
date Mon, 12 Sep 2016 17:50:11 +0200
parents 2c3d30095d5e
children e1ab82613133
line wrap: on
line diff
--- a/setup.py	Tue Oct 25 21:32:24 2016 +0200
+++ b/setup.py	Mon Sep 12 17:50:11 2016 +0200
@@ -155,6 +155,7 @@
     main = pylons.util:PylonsInstaller
 
     [gearbox.commands]
+    make-config=kallithea.lib.paster_commands.make_config:Command
     setup-db=kallithea.lib.paster_commands.setup_db:Command
     cleanup-repos=kallithea.lib.paster_commands.cleanup:Command
     update-repoinfo=kallithea.lib.paster_commands.update_repoinfo:Command