diff setup.py @ 682:23c2a0e6df0b beta

changed official rhodecode favicon, from hg to some more generic removed some unneded icons update setup to add changelog
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 13 Nov 2010 00:23:36 +0100
parents 9c8a817462fe
children 341beaa9edba
line wrap: on
line diff
--- a/setup.py	Thu Nov 11 15:31:03 2010 +0100
+++ b/setup.py	Sat Nov 13 00:23:36 2010 +0100
@@ -39,10 +39,14 @@
 #long description
 try:
     readme_file = 'README.rst'
-    long_description = open(readme_file).read()
+    changelog_file = 'docs/changelog.rst'
+    long_description = open(readme_file).read() + '/n/n' + \
+        open(changelog_file).read()
+
 except IOError, err:
     sys.stderr.write("[WARNING] Cannot find file specified as "
-        "long_description (%s)\n skipping that file" % readme_file)
+        "long_description (%s)\n or changelog (%s) skipping that file" \
+            % (readme_file, changelog_file))
     long_description = description