diff setup.py @ 552:2642f128ad46

removed egg info, update files for distutils build updated READMES some config files
author Marcin Kuzminski <marcin@python-works.com>
date Wed, 06 Oct 2010 15:37:23 +0200
parents f99075170eb4
children 65c27fd21769
line wrap: on
line diff
--- a/setup.py	Wed Oct 06 11:36:23 2010 +0200
+++ b/setup.py	Wed Oct 06 15:37:23 2010 +0200
@@ -1,4 +1,31 @@
 from rhodecode import get_version
+
+
+requirements = [
+        "Pylons>=1.0.0",
+        "SQLAlchemy>=0.6",
+        "babel",
+        "Mako>=0.3.2",
+        "vcs>=0.1.7",
+        "pygments>=1.3.0",
+        "mercurial>=1.6",
+        "pysqlite",
+        "whoosh==1.0.0",
+        "py-bcrypt",
+        "celery",
+    ]
+
+#additional files for project
+data_files = [
+              ('init.d', ['init.d/rhodecode-daemon',
+                          'init.d/rhodecode-daemon2',
+                          'init.d/celeryd']),
+              ('', ['celeryconfig.py', 'production.ini', 'development.ini']),
+              ]
+
+
+long_description = '\n' + open('README.rst').read()
+
 try:
     from setuptools import setup, find_packages
 except ImportError:
@@ -7,28 +34,18 @@
     from setuptools import setup, find_packages
 
 setup(
-    name='RhodeCode-%s' % get_version(),
+    name='RhodeCode',
     version=get_version(),
     description='Mercurial repository serving and browsing app',
+    long_description=long_description,
     keywords='mercurial web hgwebdir replacement serving hgweb rhodecode',
     license='BSD',
-    author='marcin kuzminski',
+    author='Marcin Kuzminski',
     author_email='marcin@python-works.com',
     url='http://hg.python-works.com',
-    install_requires=[
-        "Pylons>=1.0.0",
-        "SQLAlchemy>=0.6",
-        "babel",
-        "Mako>=0.3.2",
-        "vcs>=0.1.7",
-        "pygments>=1.3.0",
-        "mercurial>=1.6",
-        "pysqlite",
-        "whoosh==1.0.0b20",
-        "py-bcrypt",
-        "celery",
-    ],
+    install_requires=requirements,
     setup_requires=["PasteScript>=1.6.3"],
+    data_files=data_files,
     packages=find_packages(exclude=['ez_setup']),
     include_package_data=True,
     test_suite='nose.collector',