diff setup.py @ 4005:266a3cbc0302

Fixes some issues with keywords generation, and cleaned the code
author Marcin Kuzminski <marcin@python-works.com>
date Mon, 17 Jun 2013 15:58:20 +0200
parents 5293d4bbb1ea
children 4959e22af6ca
line wrap: on
line diff
--- a/setup.py	Mon Jun 17 15:45:30 2013 +0200
+++ b/setup.py	Mon Jun 17 15:58:20 2013 +0200
@@ -1,3 +1,4 @@
+# -*- coding: utf-8 -*-
 import os
 import sys
 import platform
@@ -95,24 +96,27 @@
 description = ('RhodeCode is a fast and powerful management tool '
                'for Mercurial and GIT with a built in push/pull server, '
                'full text search and code-review.')
-keywords = ' '.join(['rhodecode', 'rhodiumcode', 'mercurial', 'git',
-                     'code review', 'repo groups', 'ldap'
-                      'repository management', 'hgweb replacement'
-                      'hgwebdir', 'gitweb replacement', 'serving hgweb', ])
+
+keywords = ' '.join([
+    'rhodecode', 'rhodiumcode', 'mercurial', 'git', 'code review',
+    'repo groups', 'ldap', 'repository management', 'hgweb replacement',
+    'hgwebdir', 'gitweb replacement', 'serving hgweb',
+])
+
 # long description
+README_FILE = 'README.rst'
+CHANGELOG_FILE = 'docs/changelog.rst'
 try:
-    readme_file = 'README.rst'
-    changelog_file = 'docs/changelog.rst'
-    long_description = open(readme_file).read() + '\n\n' + \
-        open(changelog_file).read()
+    long_description = open(README_FILE).read() + '\n\n' + \
+        open(CHANGELOG_FILE).read()
 
 except IOError, err:
-    sys.stderr.write("[WARNING] Cannot find file specified as "
-        "long_description (%s)\n or changelog (%s) skipping that file" \
-            % (readme_file, changelog_file))
+    sys.stderr.write(
+        "[WARNING] Cannot find file specified as long_description (%s)\n or "
+        "changelog (%s) skipping that file" % (README_FILE, CHANGELOG_FILE)
+    )
     long_description = description
 
-
 try:
     from setuptools import setup, find_packages
 except ImportError: