diff setup.py @ 1965:2ba965341189

freeze hg version to 2.0.1 for windows due to a bug in mercurial that breaks forking in rhodecode-win
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 28 Jan 2012 18:11:45 +0200
parents 54e84659cb3a
children 82a88013a3fd
line wrap: on
line diff
--- a/setup.py	Sat Jan 28 07:14:01 2012 +0200
+++ b/setup.py	Sat Jan 28 18:11:45 2012 +0200
@@ -1,13 +1,10 @@
 import sys
 from rhodecode import get_version
-from rhodecode import __platform__
 from rhodecode import __license__
-from rhodecode import PLATFORM_OTHERS
+from rhodecode import __py_version__
 from rhodecode import requirements
 
-py_version = sys.version_info
-
-if py_version < (2, 5):
+if __py_version__ < (2, 5):
     raise Exception('RhodeCode requires python 2.5 or later')
 
 
@@ -25,13 +22,6 @@
                'Programming Language :: Python :: 2.6',
                'Programming Language :: Python :: 2.7', ]
 
-if py_version < (2, 6):
-    requirements.append("simplejson")
-    requirements.append("pysqlite")
-
-if __platform__ in PLATFORM_OTHERS:
-    requirements.append("py-bcrypt")
-
 
 # additional files from project that goes somewhere in the filesystem
 # relative to sys.prefix