diff setup.py @ 185:3380ca40cdba

added version generation to pylons_app and showed it into template. Propagated baseController with some data for acces into each controller. Fixed simplehg middleware to get proper name of application
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 22 May 2010 00:51:49 +0200
parents f9e8920958af
children 782f0692b29c
line wrap: on
line diff
--- a/setup.py	Fri May 21 23:52:18 2010 +0200
+++ b/setup.py	Sat May 22 00:51:49 2010 +0200
@@ -1,3 +1,4 @@
+from pylons_app import get_version
 try:
     from setuptools import setup, find_packages
 except ImportError:
@@ -7,7 +8,7 @@
 
 setup(
     name='pylons_app',
-    version='1.0',
+    version=get_version(),
     description='',
     author='marcin kuzminski',
     author_email='marcin@python-blog.com',