diff setup.py @ 857:3d0661b8aaa4

merged with beta branch
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 18 Dec 2010 14:45:58 +0100
parents d85b0948e539 b76da6f22e0f
children d9c8dddb96af
line wrap: on
line diff
--- a/setup.py	Thu Nov 18 21:35:52 2010 +0100
+++ b/setup.py	Sat Dec 18 14:45:58 2010 +0100
@@ -1,27 +1,28 @@
-from rhodecode import get_version
 import sys
 py_version = sys.version_info
 
+from rhodecode import get_version
+
 requirements = [
-        "Pylons>=1.0.0",
+        "Pylons==1.0.0",
         "SQLAlchemy==0.6.5",
-        "Mako>=0.3.2",
-        "vcs==0.1.8",
-        "pygments>=1.3.0",
-        "mercurial==1.6.4",
-        "whoosh==1.2.5",
-        "celery==2.1.3",
+        "Mako==0.3.6",
+        "vcs==0.1.10",
+        "pygments==1.3.1",
+        "mercurial==1.7.2",
+        "whoosh==1.3.4",
+        "celery==2.1.4",
         "py-bcrypt",
         "babel",
     ]
 
-classifiers = ["Development Status :: 5 - Production/Stable",
-                   'Environment :: Web Environment',
-                   'Framework :: Pylons',
-                   'Intended Audience :: Developers',
-                   'License :: OSI Approved :: BSD License',
-                   'Operating System :: OS Independent',
-                   'Programming Language :: Python', ]
+classifiers = ['Development Status :: 5 - Production/Stable',
+               'Environment :: Web Environment',
+               'Framework :: Pylons',
+               'Intended Audience :: Developers',
+               'License :: OSI Approved :: BSD License',
+               'Operating System :: OS Independent',
+               'Programming Language :: Python', ]
 
 if sys.version_info < (2, 6):
     requirements.append("simplejson")
@@ -34,14 +35,19 @@
 #additional files that goes into package itself
 package_data = {'rhodecode': ['i18n/*/LC_MESSAGES/*.mo', ], }
 
-description = 'Mercurial repository serving and browsing app'
+description = ('Mercurial repository browser/management with '
+               'build in push/pull server and full text search')
 #long description
 try:
     readme_file = 'README.rst'
-    long_description = open(readme_file).read()
+    changelog_file = 'docs/changelog.rst'
+    long_description = open(readme_file).read() + '/n/n' + \
+        open(changelog_file).read()
+
 except IOError, err:
     sys.stderr.write("[WARNING] Cannot find file specified as "
-        "long_description (%s)\n skipping that file" % readme_file)
+        "long_description (%s)\n or changelog (%s) skipping that file" \
+            % (readme_file, changelog_file))
     long_description = description
 
 
@@ -59,7 +65,7 @@
     version=get_version(),
     description=description,
     long_description=long_description,
-    keywords='rhodiumcode mercurial web hgwebdir replacement serving hgweb rhodecode',
+    keywords='rhodiumcode mercurial web hgwebdir gitweb git replacement serving hgweb rhodecode',
     license='BSD',
     author='Marcin Kuzminski',
     author_email='marcin@python-works.com',
@@ -84,5 +90,14 @@
 
     [paste.app_install]
     main = pylons.util:PylonsInstaller
+
+    [paste.global_paster_command]
+    make-index = rhodecode.lib.indexers:MakeIndex
+    upgrade-db = rhodecode.lib.dbmigrate:UpgradeDb
+    celeryd=rhodecode.lib.celerypylons.commands:CeleryDaemonCommand
+    celerybeat=rhodecode.lib.celerypylons.commands:CeleryBeatCommand
+    camqadm=rhodecode.lib.celerypylons.commands:CAMQPAdminCommand
+    celeryev=rhodecode.lib.celerypylons.commands:CeleryEventCommand
+              
     """,
 )