diff setup.py @ 1915:54e84659cb3a

fixes for release 1.2.4 - docs updates - requires.txt file - changelog
author Marcin Kuzminski <marcin@python-works.com>
date Thu, 19 Jan 2012 06:46:25 +0200
parents 3246fcce2402
children 2ba965341189
line wrap: on
line diff
--- a/setup.py	Tue Jan 17 20:53:25 2012 +0200
+++ b/setup.py	Thu Jan 19 06:46:25 2012 +0200
@@ -3,29 +3,13 @@
 from rhodecode import __platform__
 from rhodecode import __license__
 from rhodecode import PLATFORM_OTHERS
+from rhodecode import requirements
 
 py_version = sys.version_info
 
 if py_version < (2, 5):
     raise Exception('RhodeCode requires python 2.5 or later')
 
-requirements = [
-        "Pylons==1.0.0",
-        "Beaker==1.5.4",
-        "WebHelpers>=1.2",
-        "formencode==1.2.4",
-        "SQLAlchemy==0.7.3",
-        "Mako==0.5.0",
-        "pygments>=1.4",
-        "mercurial>=2.0,<2.1",
-        "whoosh<1.8",
-        "celery>=2.2.5,<2.3",
-        "babel",
-        "python-dateutil>=1.5.0,<2.0.0",
-        "dulwich>=0.8.0,<0.9.0",
-        "vcs==0.2.2",
-        "webob==1.0.8"
-    ]
 
 dependency_links = [
 ]