diff setup.py @ 457:644795a4e8d2

Code cleanups, made js rollup file, some preparation for .egg creation
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 04 Sep 2010 15:20:06 +0200
parents 6b54caa8b074
children 91292686c1ed
line wrap: on
line diff
--- a/setup.py	Sat Sep 04 00:17:01 2010 +0200
+++ b/setup.py	Sat Sep 04 15:20:06 2010 +0200
@@ -7,7 +7,7 @@
     from setuptools import setup, find_packages
 
 setup(
-    name='hg-app',
+    name='HgApp-%s'%get_version(),
     version=get_version(),
     description='Mercurial repository serving and browsing app',
     keywords='mercurial web hgwebdir replacement serving hgweb',
@@ -18,12 +18,13 @@
     install_requires=[
         "Pylons>=1.0.0",
         "SQLAlchemy>=0.6",
+        "babel",
         "Mako>=0.3.2",
         "vcs>=0.1.4",
         "pygments>=1.3.0",
         "mercurial>=1.6",
         "pysqlite",
-        "whoosh==1.0.0b9",
+        "whoosh==1.0.0b10",
         "py-bcrypt",
     ],
     setup_requires=["PasteScript>=1.6.3"],