diff setup.py @ 8364:68d4aae74194 i18n

Merge default pre 0.6
author Mads Kiilerich <mads@kiilerich.com>
date Mon, 27 Apr 2020 13:25:28 +0200
parents bee01ae374a2
children e3a3fae57343
line wrap: on
line diff
--- a/setup.py	Mon Apr 13 21:40:33 2020 +0200
+++ b/setup.py	Mon Apr 27 13:25:28 2020 +0200
@@ -20,16 +20,17 @@
     import re
     matches = re.compile(r'(?:%s)\s*=\s*(.*)' % name).search(data)
     if matches:
-        if not callable(callback_handler):
-            callback_handler = lambda v: v
-
-        return callback_handler(eval(matches.groups()[0]))
+        s = eval(matches.groups()[0])
+        if callable(callback_handler):
+            return callback_handler(s)
+        return s
 
 _meta = open(os.path.join(here, 'kallithea', '__init__.py'), 'r')
 _metadata = _meta.read()
 _meta.close()
 
-callback = lambda V: ('.'.join(map(str, V[:3])) + '.'.join(V[3:]))
+def callback(V):
+    return '.'.join(map(str, V[:3])) + '.'.join(V[3:])
 __version__ = _get_meta_var('VERSION', _metadata, callback)
 __license__ = _get_meta_var('__license__', _metadata)
 __author__ = _get_meta_var('__author__', _metadata)
@@ -40,9 +41,9 @@
 is_windows = __platform__ in ['Windows']
 
 requirements = [
-    "alembic >= 1.0.10, < 1.1",
+    "alembic >= 1.0.10, < 1.5",
     "gearbox >= 0.1.0, < 1",
-    "waitress >= 0.8.8, < 1.4",
+    "waitress >= 0.8.8, < 1.5",
     "WebOb >= 1.8, < 1.9",
     "backlash >= 0.1.2, < 1",
     "TurboGears2 >= 2.4, < 2.5",
@@ -51,30 +52,29 @@
     "WebHelpers2 >= 2.0, < 2.1",
     "FormEncode >= 1.3.1, < 1.4",
     "SQLAlchemy >= 1.2.9, < 1.4",
-    "Mako >= 0.9.1, < 1.1",
-    "Pygments >= 2.2.0, < 2.5",
+    "Mako >= 0.9.1, < 1.2",
+    "Pygments >= 2.2.0, < 2.6",
     "Whoosh >= 2.7.1, < 2.8",
-    "celery >= 3.1, < 4.0", # TODO: celery 4 doesn't work
-    "Babel >= 1.3, < 2.8",
+    "celery >= 4.3, < 4.5",
+    "Babel >= 1.3, < 2.9",
     "python-dateutil >= 2.1.0, < 2.9",
     "Markdown >= 2.2.1, < 3.2",
-    "docutils >= 0.11, < 0.15",
+    "docutils >= 0.11, < 0.17",
     "URLObject >= 2.3.4, < 2.5",
     "Routes >= 2.0, < 2.5",
     "dulwich >= 0.19.0, < 0.20",
-    "mercurial >= 5.2, < 5.4",
+    "mercurial >= 5.2, < 5.5",
     "decorator >= 4.2.1, < 4.5",
-    "Paste >= 2.0.3, < 3.1",
-    "bleach >= 3.0, < 3.2",
+    "Paste >= 2.0.3, < 3.4",
+    "bleach >= 3.0, < 3.1.4",
     "Click >= 7.0, < 8",
     "ipaddr >= 2.2.0, < 2.3",
     "paginate >= 0.5, < 0.6",
     "paginate_sqlalchemy >= 0.3.0, < 0.4",
+    "bcrypt >= 3.1.0, < 3.2",
+    "pip >= 20.0, < 999",
 ]
 
-if not is_windows:
-    requirements.append("bcrypt >= 3.1.0, < 3.2")
-
 dependency_links = [
 ]
 
@@ -112,8 +112,8 @@
     long_description = open(README_FILE).read()
 except IOError as err:
     sys.stderr.write(
-        "[WARNING] Cannot find file specified as long_description (%s)\n"
-        % README_FILE
+        "[WARNING] Cannot find file specified as long_description (%s): %s\n"
+        % (README_FILE, err)
     )
     long_description = description