diff setup.py @ 2597:7b092b919f4f beta

Switch to waitress wsgi server by default in rhodecode. - waitress is fast, handles chunked encoding correctly (needed for git) - waitress works on linux and windows - it's now default because it can handle git properly out of the box.
author Marcin Kuzminski <marcin@python-works.com>
date Fri, 13 Jul 2012 21:17:38 +0200
parents 9382e88eae22
children 17083006a33d
line wrap: on
line diff
--- a/setup.py	Fri Jul 13 14:32:45 2012 +0200
+++ b/setup.py	Fri Jul 13 21:17:38 2012 +0200
@@ -33,6 +33,7 @@
 is_windows = __platform__ in _get_meta_var('PLATFORM_WIN', _metadata)
 
 requirements = [
+    "waitress==0.8.1",
     "Pylons==1.0.0",
     "Beaker==1.6.3",
     "WebHelpers==1.3",
@@ -49,7 +50,7 @@
     "markdown==2.1.1",
     "docutils==0.8.1",
     "simplejson==2.5.2",
-    "mock"
+    "mock",
 ]
 
 if sys.version_info < (2, 6):