diff setup.py @ 8215:928bc1d8b279 default-i18n

Merge from default
author Mads Kiilerich <mads@kiilerich.com>
date Thu, 06 Feb 2020 01:19:23 +0100
parents 01aca0a4f876
children d122a9532630
line wrap: on
line diff
--- a/setup.py	Sun Jan 05 01:19:05 2020 +0100
+++ b/setup.py	Thu Feb 06 01:19:23 2020 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python2
+#!/usr/bin/env python3
 # -*- coding: utf-8 -*-
 import os
 import platform
@@ -9,8 +9,8 @@
 from setuptools.command import sdist
 
 
-if sys.version_info < (2, 6) or sys.version_info >= (3,):
-    raise Exception('Kallithea requires python 2.7')
+if sys.version_info < (3, 6):
+    raise Exception('Kallithea requires Python 3.6 or later')
 
 
 here = os.path.abspath(os.path.dirname(__file__))
@@ -25,7 +25,7 @@
 
         return callback_handler(eval(matches.groups()[0]))
 
-_meta = open(os.path.join(here, 'kallithea', '__init__.py'), 'rb')
+_meta = open(os.path.join(here, 'kallithea', '__init__.py'), 'r')
 _metadata = _meta.read()
 _meta.close()
 
@@ -40,35 +40,36 @@
 is_windows = __platform__ in ['Windows']
 
 requirements = [
-    "alembic >= 0.8.0, < 1.1",
+    "alembic >= 1.0.10, < 1.1",
     "gearbox >= 0.1.0, < 1",
     "waitress >= 0.8.8, < 1.4",
-    "WebOb >= 1.7, < 1.9",
+    "WebOb >= 1.8, < 1.9",
     "backlash >= 0.1.2, < 1",
-    "TurboGears2 >= 2.3.10, < 2.5",
+    "TurboGears2 >= 2.4, < 2.5",
     "tgext.routes >= 0.2.0, < 1",
-    "Beaker >= 1.7.0, < 2",
-    "WebHelpers >= 1.3, < 1.4",
+    "Beaker >= 1.10.1, < 2",
     "WebHelpers2 >= 2.0, < 2.1",
-    "FormEncode >= 1.3.0, < 1.4",
-    "SQLAlchemy >= 1.1, < 1.4",
-    "Mako >= 0.9.0, < 1.1",
+    "FormEncode >= 1.3.1, < 1.4",
+    "SQLAlchemy >= 1.2.9, < 1.4",
+    "Mako >= 0.9.1, < 1.1",
     "Pygments >= 2.2.0, < 2.5",
-    "Whoosh >= 2.5.0, < 2.8",
+    "Whoosh >= 2.7.1, < 2.8",
     "celery >= 3.1, < 4.0", # TODO: celery 4 doesn't work
     "Babel >= 1.3, < 2.8",
-    "python-dateutil >= 1.5.0, < 2.9",
+    "python-dateutil >= 2.1.0, < 2.9",
     "Markdown >= 2.2.1, < 3.2",
     "docutils >= 0.11, < 0.15",
     "URLObject >= 2.3.4, < 2.5",
-    "Routes >= 1.13, < 2", # TODO: bumping to 2.0 will make test_file_annotation fail
-    "dulwich >= 0.14.1, < 0.20",
-    "mercurial >= 4.5, < 5.3",
-    "decorator >= 3.3.2, < 4.5",
+    "Routes >= 2.0, < 2.5",
+    "dulwich >= 0.19.0, < 0.20",
+    "mercurial >= 5.2, < 5.4",
+    "decorator >= 4.2.1, < 4.5",
     "Paste >= 2.0.3, < 3.1",
     "bleach >= 3.0, < 3.2",
     "Click >= 7.0, < 8",
-    "ipaddr >= 2.1.10, < 2.3",
+    "ipaddr >= 2.2.0, < 2.3",
+    "paginate >= 0.5, < 0.6",
+    "paginate_sqlalchemy >= 0.3.0, < 0.4",
 ]
 
 if not is_windows:
@@ -84,8 +85,9 @@
     'Intended Audience :: Developers',
     'License :: OSI Approved :: GNU General Public License (GPL)',
     'Operating System :: OS Independent',
-    'Programming Language :: Python',
-    'Programming Language :: Python :: 2.7',
+    'Programming Language :: Python :: 3.6',
+    'Programming Language :: Python :: 3.7',
+    'Programming Language :: Python :: 3.8',
     'Topic :: Software Development :: Version Control',
 ]