diff setup.py @ 8124:a553bc3a3d0e

py3: open files as binary or not, depending on how we want to use them The difference will matter when bytes and str are different.
author Mads Kiilerich <mads@kiilerich.com>
date Fri, 27 Dec 2019 01:46:11 +0100
parents 1e8b300b0540
children b72e8b7c33ae
line wrap: on
line diff
--- a/setup.py	Thu Jan 02 23:19:36 2020 +0100
+++ b/setup.py	Fri Dec 27 01:46:11 2019 +0100
@@ -25,7 +25,7 @@
 
         return callback_handler(eval(matches.groups()[0]))
 
-_meta = open(os.path.join(here, 'kallithea', '__init__.py'), 'rb')
+_meta = open(os.path.join(here, 'kallithea', '__init__.py'), 'r')
 _metadata = _meta.read()
 _meta.close()