diff setup.py @ 7708:ab30729c735c

setup: drop support for Python 2.6 It would be a a stepping stone for the migration to Python 3 to only support Python 2.7. Even though we don't make any big changes now, it might allow us to remove some workarounds or use some new forward-compatible features. Mercurial dropped support for Python 2.6 2 years ago.
author Mads Kiilerich <mads@kiilerich.com>
date Wed, 01 May 2019 22:44:51 +0200
parents 953047e8c88a
children 0572d5d132c2
line wrap: on
line diff
--- a/setup.py	Sun May 26 23:25:04 2019 +0200
+++ b/setup.py	Wed May 01 22:44:51 2019 +0200
@@ -5,7 +5,7 @@
 import platform
 
 if sys.version_info < (2, 6) or sys.version_info >= (3,):
-    raise Exception('Kallithea requires python 2.6 or 2.7')
+    raise Exception('Kallithea requires python 2.7')
 
 
 here = os.path.abspath(os.path.dirname(__file__))
@@ -82,7 +82,6 @@
     'License :: OSI Approved :: GNU General Public License (GPL)',
     'Operating System :: OS Independent',
     'Programming Language :: Python',
-    'Programming Language :: Python :: 2.6',
     'Programming Language :: Python :: 2.7',
     'Topic :: Software Development :: Version Control',
 ]