diff setup.py @ 564:ba7e24cd4786

refactor codes and setup for python 2.5 readme update
author Marcin Kuzminski <marcin@python-works.com>
date Sat, 09 Oct 2010 16:05:14 +0200
parents 65c27fd21769
children ad2e97c6f17f
line wrap: on
line diff
--- a/setup.py	Sat Oct 09 01:38:10 2010 +0200
+++ b/setup.py	Sat Oct 09 16:05:14 2010 +0200
@@ -1,5 +1,6 @@
 from rhodecode import get_version
 import sys
+py_version = sys.version_info
 
 requirements = [
         "Pylons>=1.0.0",
@@ -9,12 +10,15 @@
         "vcs>=0.1.7",
         "pygments>=1.3.0",
         "mercurial>=1.6",
-        "pysqlite",
         "whoosh==1.0.0",
         "py-bcrypt",
         "celery",
     ]
 
+if sys.version_info < (2, 6):
+    requirements.append("simplejson")
+    requirements.append("pysqlite")
+
 #additional files from project that goes somewhere in the filesystem
 #relative to sys.prefix
 data_files = []