diff setup.py @ 7899:bec4bc21f845

setup.py: bump Pygments minimum version to 2.2.0 With pygments < 2.2.0, the markup_renderer doctest fails: > python -m doctest kallithea/lib/markup_renderer.py ********************************************************************** File "kallithea/lib/markup_renderer.py", line 184, in markup_renderer.MarkupRenderer.markdown Failed example: print MarkupRenderer.markdown(''' #!/bin/bash echo "hello" ''') Expected: <table class="code-highlighttable"><tr><td class="linenos"><div class="linenodiv"><pre>1 2</pre></div></td><td class="code"><div class="code-highlight"><pre><span></span><span class="ch">#!/bin/bash</span> <span class="nb">echo</span> <span class="s2">&quot;hello&quot;</span> </pre></div> </td></tr></table> Got: <table class="code-highlighttable"><tr><td class="linenos"><div class="linenodiv"><pre>1 2</pre></div></td><td class="code"><div class="code-highlight"><pre><span class="ch">#!/bin/bash</span> <span class="nb">echo</span> <span class="s2">&quot;hello&quot;</span> </pre></div> </td></tr></table> ********************************************************************** To avoid having to manage multiple outputs from multiple versions, just bump the lower version. pygments 2.2.0 was released on Jan 22, 2017.
author Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
date Mon, 21 Oct 2019 21:55:58 +0200
parents 9d74cc23ea64
children 8e0efe7b3b10
line wrap: on
line diff
--- a/setup.py	Sun Oct 27 18:29:52 2019 +0100
+++ b/setup.py	Mon Oct 21 21:55:58 2019 +0200
@@ -53,7 +53,7 @@
     "FormEncode >= 1.3.0, < 1.4",
     "SQLAlchemy >= 1.1, < 1.4",
     "Mako >= 0.9.0, < 1.1",
-    "Pygments >= 2.0, < 2.5",
+    "Pygments >= 2.2.0, < 2.5",
     "Whoosh >= 2.5.0, < 2.8",
     "celery >= 3.1, < 4.0", # TODO: celery 4 doesn't work
     "Babel >= 1.3, < 2.8",