diff setup.cfg @ 5700:d88077fae3d6

pytest migration: switch to pytest; remove nose support Make pytest the default test runner and remove support for nose. Tests can be run using: - py.test - python setup.py test The pytest configuration needs to move from setup.cfg to pytest.ini to support this - see https://github.com/pytest-dev/pytest/issues/567 and https://bitbucket.org/pytest-dev/pytest-runner/issues/7/support-all-pytest-commands .
author Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
date Wed, 03 Feb 2016 22:32:28 +0100
parents 19267f233d39
children 0a2d85671b59
line wrap: on
line diff
--- a/setup.cfg	Wed Feb 03 22:14:36 2016 +0100
+++ b/setup.cfg	Wed Feb 03 22:32:28 2016 +0100
@@ -3,22 +3,8 @@
 tag_svn_revision = 0
 tag_date = 0
 
-[nosetests]
-verbose = True
-verbosity = 2
-with-pylons = kallithea/tests/test.ini
-detailed-errors = 1
-nologcapture = 1
-
-[pytest]
-# only look for tests in kallithea/tests
-python_files = kallithea/tests/**/test_*.py
-addopts =
-    # --verbose
-    # show extra test summary info as specified by chars (f)ailed, (E)error, (s)skipped, (x)failed, (X)passed, (w)warnings.
-    -rfEsxXw
-    # Shorter scrollbacks; less stuff to scroll through
-    --tb=short
+[aliases]
+test = pytest
 
 [compile_catalog]
 domain = kallithea