diff setup.py @ 6026:dd676fdeda0f

setup: move test dependencies to dev_requirements.txt to make them optional Remove the need for having test tools on production systems. Installing test dependencies is made an extra explicit step. pip is the future, but doesn't have the same tests_require features as setuptools kind of has. I don't like this way of handling it without setup.py support and with explicit naming of the ugly dev_requirements.txt ... but that seems to be the way to do it.
author Mads Kiilerich <madski@unity3d.com>
date Thu, 28 Jul 2016 16:28:34 +0200
parents 1a080d4e926e
children 94db428caa4e
line wrap: on
line diff
--- a/setup.py	Wed Jul 13 21:39:14 2016 +0200
+++ b/setup.py	Thu Jul 28 16:28:34 2016 +0200
@@ -38,7 +38,6 @@
     "alembic>=0.8.0,<0.9",
     "waitress==0.8.8",
     "webob>=1.0.8,<=1.1.1",
-    "webtest==1.4.3",
     "Pylons>=1.0.0,<=1.0.2",
     "Beaker==1.6.4",
     "WebHelpers==1.3",
@@ -52,24 +51,19 @@
     "python-dateutil>=1.5.0,<2.0.0",
     "markdown==2.2.1",
     "docutils>=0.8.1,<=0.11",
-    "mock",
     "URLObject==2.3.4",
     "Routes==1.13",
-    "pytest>=2.7.0,<3.0",
-    "pytest-sugar>=0.7.0,<1.0.0",
     "dulwich>=0.14.1",
     "mercurial>=2.9,<3.9",
 ]
 
 if sys.version_info < (2, 7):
     requirements.append("importlib==1.0.1")
-    requirements.append("unittest2")
     requirements.append("argparse")
 
 if not is_windows:
     requirements.append("bcrypt>=2.0.0")
 
-
 dependency_links = [
 ]
 
@@ -147,9 +141,7 @@
     url=__url__,
     install_requires=requirements,
     classifiers=classifiers,
-    setup_requires=['PasteScript>=1.6.3',
-                    'pytest-runner'],
-    tests_require=['pytest'],
+    setup_requires=['PasteScript>=1.6.3'],
     data_files=data_files,
     packages=packages,
     include_package_data=True,