diff setup.py @ 4116:ffd45b185016 rhodecode-2.2.5-gpl

Imported some of the GPLv3'd changes from RhodeCode v2.2.5. This imports changes between changesets 21af6c4eab3d and 6177597791c2 in RhodeCode's original repository, including only changes to Python files and HTML. RhodeCode clearly licensed its changes to these files under GPLv3 in their /LICENSE file, which states the following: The Python code and integrated HTML are licensed under the GPLv3 license. (See: https://code.rhodecode.com/rhodecode/files/v2.2.5/LICENSE or http://web.archive.org/web/20140512193334/https://code.rhodecode.com/rhodecode/files/f3b123159901f15426d18e3dc395e8369f70ebe0/LICENSE for an online copy of that LICENSE file) Conservancy reviewed these changes and confirmed that they can be licensed as a whole to the Kallithea project under GPLv3-only. While some of the contents committed herein are clearly licensed GPLv3-or-later, on the whole we must assume the are GPLv3-only, since the statement above from RhodeCode indicates that they intend GPLv3-only as their license, per GPLv3ยง14 and other relevant sections of GPLv3.
author Bradley M. Kuhn <bkuhn@sfconservancy.org>
date Wed, 02 Jul 2014 19:03:13 -0400
parents f292547dadd0
children aaa7c3331186
line wrap: on
line diff
--- a/setup.py	Wed Jul 02 19:03:10 2014 -0400
+++ b/setup.py	Wed Jul 02 19:03:13 2014 -0400
@@ -34,7 +34,7 @@
 is_windows = __platform__ in ['Windows']
 
 requirements = [
-    "waitress==0.8.4",
+    "waitress==0.8.8",
     "webob==1.0.8",
     "webtest==1.4.3",
     "Pylons==1.0.0",
@@ -42,38 +42,42 @@
     "WebHelpers==1.3",
     "formencode==1.2.4",
     "SQLAlchemy==0.7.10",
-    "Mako==0.7.3",
+    "Mako==0.9.0",
     "pygments>=1.5",
     "whoosh>=2.4.0,<2.5",
     "celery>=2.2.5,<2.3",
-    "babel",
+    "babel==0.9.6",
     "python-dateutil>=1.5.0,<2.0.0",
-    "dulwich>=0.8.7,<0.9.0",
+    "dulwich==0.9.3",
     "markdown==2.2.1",
     "docutils==0.8.1",
     "simplejson==2.5.2",
     "mock",
+    "pycrypto==2.6.0",
+    "URLObject==2.3.4",
+    "Routes==1.13",
 ]
 
 if sys.version_info < (2, 6):
     requirements.append("pysqlite")
 
 if sys.version_info < (2, 7):
+    requirements.append("importlib==1.0.1")
     requirements.append("unittest2")
     requirements.append("argparse")
 
 if is_windows:
-    requirements.append("mercurial==2.6.3")
+    requirements.append("mercurial==2.8.2")
 else:
-    requirements.append("py-bcrypt")
-    requirements.append("mercurial==2.6.3")
+    requirements.append("py-bcrypt==0.3.0")
+    requirements.append("mercurial==2.8.2")
 
 
 dependency_links = [
 ]
 
 classifiers = [
-    'Development Status :: 5 - Production/Stable',
+    'Development Status :: 4 - Beta'
     'Environment :: Web Environment',
     'Framework :: Pylons',
     'Intended Audience :: Developers',
@@ -166,7 +170,6 @@
 
     [paste.global_paster_command]
     setup-rhodecode=rhodecode.lib.paster_commands.setup_rhodecode:Command
-    cleanup-repos=rhodecode.lib.paster_commands.cleanup:Command
     update-repoinfo=rhodecode.lib.paster_commands.update_repoinfo:Command
     make-rcext=rhodecode.lib.paster_commands.make_rcextensions:Command
     repo-scan=rhodecode.lib.paster_commands.repo_scan:Command