view pytest.ini @ 8598:eb486c0c3114

scm: refactor install_git_hooks Rename, simplify, and negate some logic to make the flow more readable to me and give better logging. For example, "force_create" were more about "force overwrite". Calling it "force" is more precise.
author Mads Kiilerich <mads@kiilerich.com>
date Mon, 20 Jul 2020 19:46:30 +0200
parents afa5e0bdb76f
children
line wrap: on
line source

[pytest]
# only look for tests in kallithea/tests
python_files = kallithea/tests/**/test_*.py
addopts =
    # --verbose
    # show extra test summary info as specified by chars (f)ailed, (E)error, (s)skipped, (x)failed, (X)passed, (w)warnings.
    -rfEsxXw
    # Shorter scrollbacks; less stuff to scroll through
    --tb=short
    #
    --doctest-modules
    --doctest-ignore-import-errors